en-USfr-FR

Latest News published...

20


Some looks of Magic Bullet Looks... The end of display problem with Magic Bullet from Red Giant !

 

 

Do you have problems with Magic Bullet, a plugin from Red Giant within Avid/Pinnacle Studio ? You have:

  • an ATI graphic card ?
  • Magic Bullet plugin for Pinnacle Studio which display a blank or black screen without any preview ?

In such case, it seems that your problem are ended ! Indeed, ATI just launched new drivers for your graphic card, hurry up and update your computer.
Take note that these problems appear with Catalyst V 10.5, and was present in a huge number of cases. With the latest 10.12 Catalyst version and driver, the problem disappear !! Wonderfull ! Thanks to Francis57 and JCD59, they ensure a follow up of the problem and done many test (and also helped me to solve the problem !!).

So if you did not already update your driver, do so : "download the latest 10.12 ATI driver"

You have the option to download:

  • driver only (file ending with ..._dd.exe) and then I strongly recommend "Catalyst Control Center" (file ending with ..._ccc_lang3.exe)
  • otherwise the Catalyst Control Center pack (file ending with  ..._ccc_enu.exe)
  • or finally, Catalyst Control Center APP pack (file ending with  ..._ccc_ocl.exe) - This pack contains the latest technology to make your GPU working for rendering, instead of your CPU

All people who managed to solve the problem done the following: installing driver only (..._dd.exe) followed by the installation of the full Catalyst Control Center APP Pack (it seems that installing the full package does not solve the problem).

Information from Graham P (N-Vidia graphic card) :
For those of you who have Nvidia cards, without driver issues, it can be a systems app. that is stopping it. I had to go into system configuration and turn off half and half again until I found it (Windows event log). I turned the bugger off and voila there was looks builder in all it's glory. That and the HFX creator are my two favorite apps...

If you do not know what Magic Bullet is, please read: Magic Bullet Looks : Overview
Finally, if you want to know more about a graphic card, read: What do you know about your graphic card ?

 

Actions: E-mail | Permalink | Comments (40) RSS comment feed | Bookmark and Share


Comments

Joe
#Joe
Saturday, January 1, 2011 10:47 PM
I've been having problems with magic bullets for two months. I was concerned that the drivers listed above wouldn't work with my FirePro ATI graphics card. I downloaded the new Beta drivers for the FirePro Cards and it's operational again.
Here is a link for those: FirePro workstation cards instead of Radeon Cards.
Déclic Vidéo FX
#Déclic Vidéo FX
Friday, January 7, 2011 4:50 AM
Thanks Joe, very interesting !!

DV FX
Joe
#Joe
Friday, January 7, 2011 9:13 AM
I have one of the 4800 Series FirePro workstation cards. I recently switched over to it from a crossfire configuration I was using with two 4850 ATI cards believing that they were causing the problems I had with magic bullets. Now I'm confident the crossfire configuration wasn't it. It was the drivers all along.
After a about a week magic bullets is working just fine but, I'm wondering if my graphics card is working for rendering instead of my processor. I'm running a AMD 1075T Hexacore CPU. Any suggestions out there to know which is doing the grunt work of rendering?
Thanks for any responses.
Déclic Vidéo FX
#Déclic Vidéo FX
Saturday, January 8, 2011 2:58 PM
As far as I know, with Pinnacle Studio, the processor is doing the rendering... Not the GPU. GPU is only here for display.
BUT, with proDAD products, like VitaScene, the GPU is doing the rendering. In Studio, that's the same problem, I am not sure whether it is handled by the GPU or processor. I will ask proDAD if they know... Might be the same with Magic Bullet ???

Any other suggestion or advice is welcomed. Do not hesitate.

DV FX
Déclic Vidéo FX
#Déclic Vidéo FX
Sunday, January 9, 2011 2:18 PM
Hello Joe,

Here is the answer from proDAD: Studio and VitaScene are using GPU for the realtime effects.

DV FX
Graham
#Graham
Sunday, January 9, 2011 4:53 PM
I started out with an ATI 5470 card and although I couldn't figure out how to use magic bullet it did open and display it.Because that card was totaly inadequate I switched it out for an EVGA GTS 450,I use an ASUS CG1330 with a AMD Phenom Hex core 1045T with 8 gigs of ram,a 1TB 'C' drive and a 320 gig project drive and windows 7.I read your wonderful tutorial realized how simple it was and went to use it.Crashed the program until I cleaned up the start program list.Now I get 'can not unlock magic bullet'.What now?Oh yes my studio 14 is the ultimate collection upgrade version.Thank you for any help you can give me.
Joe
#Joe
Sunday, January 9, 2011 7:20 PM
Yesterday I just switched over from Vista 64 to Windows 7 64bit. I didn't know it would make a difference but, with background rendering on it seems to be a little snappier.
I'm still kind of wondering when Pinnacle will come out with it's new version of Studio? Any buzz about the release date of Studio 15?
Thanks for all the advice.

Joe
Déclic Vidéo FX
#Déclic Vidéo FX
Wednesday, January 12, 2011 1:36 PM
@ Joe, You could read Is Pinnacle launching Studio 15 ?
@ Graham, have you tried AVID Unlock website ?

DV FX
Shane
#Shane
Saturday, February 5, 2011 10:41 PM
I have Studio 14 and magic bullet won't load......I keep getting a message saying not responding. I am running vista 32 with a nvidia 9800gt with a Intel C2Q8200 CPU 2.33 on a gigabyte ga-p31 board. I have downloaded the lasted drivers for my card.......still no luck....any suggesstions??
Déclic Vidéo FX
#Déclic Vidéo FX
Sunday, February 6, 2011 2:43 PM
Hello Shane,

It has nothing to do with the display problem we are talking about here. I would suggest that you check AVID knowledge base by searching Magic Bullet as a keyword, you have some tips to solve your problem.

Regards,
DV FX
Shane
#Shane
Sunday, February 6, 2011 6:28 PM
Thanks for the heads up.........I have done numerous searches for a solution I will try your link now. What I forgot to mention was that I had no issues with magic bullet running on my old XP computer.....Is it possible that it is a vista issue??........
Cheers
Graham P.
#Graham P.
Thursday, February 10, 2011 1:47 PM
I have tried every thing suggested here.Re installed Magic bullet,ran a clean boot,will re-installing studio 14 help?For one session everything worked just fine.Than a windows update than back to crashing.Just calling up a project with magic bullet causes it to crash.I restored it to the previous session and no luck,clean boot no luck,re-installing magic bullet no luck.
Graham P.
#Graham P.
Thursday, February 10, 2011 10:19 PM
I have come back to this forum because the Avid knowledge base is almost useless.Perhaps this means that they consider these problems not to be software issues there fore not their responsibility.Which I can understand,that's why there is a need for sites like these.
Déclic Vidéo FX
#Déclic Vidéo FX
Monday, February 14, 2011 2:48 PM
Graham,

You do not tell us which graphic card you have, if it's similar to the issue we are dealing with, or if it's something different ???

DV FX
fishnwithjoe@yahoo.com
#fishnwithjoe@yahoo.com
Thursday, February 17, 2011 3:19 PM
They did it. They did it. Two version of regular Studio 15 ( HD & Ultimate collection) then a new version called AVID Studio. The new AVID version has unlimited tracks. WoW!!!
graham p
#graham p
Saturday, February 19, 2011 8:06 PM
I am sorry.It is an EVGA450GTS.I get a black display area with a tool bar in the upper left hand corner that does not respond to command.Than followed by," sorry can not unlock application".At this point windows shuts it downs and returns to the time line.Once it worked for a full session and when I returned it was gone again.I tried to restore it but it still did not respond.Maybe installing the AVID upgrade will fix it ?I really want it but I got to get this working if it doesn't.Thanks
Déclic Vidéo FX
#Déclic Vidéo FX
Sunday, February 20, 2011 2:32 PM
Hello Graham p,

Have you checked AVID knowledge base by searching Magic Bullet as a keyword, you have some tips to solve your problem.

Regards,
DV FX
JoJoJo
#JoJoJo
Tuesday, February 22, 2011 5:04 AM
I still have problems with Magic Bullet (display a blank or black screen without any preview, no error message....)

I have installed the newest CatalystDriver 11.2.
I use a "ATI Radeon 5650 1 GB" Grafikcard (newest Driver)


I have checked the Avid database (no answer available)
Déclic Vidéo FX
#Déclic Vidéo FX
Tuesday, February 22, 2011 2:25 PM
Hello JoJoJo,

Can you download and install the driver we described ? ATI Catalyst 10.12
For the latest release, I do not know if it fully works or not. On Catalyst website you have the possibility to download previous driver. But you might need to roll back to previous state (using Windows recovery or similar).

DV FX
JoJoJo
#JoJoJo
Wednesday, February 23, 2011 2:31 AM
Thank you for your response
I have downloaded 4 Files:
10-12..._dd.exe (Driver)
10-12.._ccc_lang2.exe (language)

10-12..._ccc_enu.exe (Catalyst COntrol Center)
10-12..._ocl.exe (Open CL Driver)

Do have have to install this in that order, all Files ?
At the moment i have the newsest Driver installed , it is possible do downgrade with this files ?
Thank you in advance for help
Déclic Vidéo FX
#Déclic Vidéo FX
Wednesday, February 23, 2011 3:09 PM
Hello JoJoJo,

To my knowledge, it's difficult to downgrade... You might give it a try ??
And to answer your question, it's written in our article:
All people who managed to solve the problem done the following: installing driver only (..._dd.exe) followed by the installation of the full Catalyst Control Center APP Pack (it seems that installing the full package does not solve the problem).

DV FX
JoJoJo
#JoJoJo
Friday, February 25, 2011 2:01 AM
Yes, it worked.
I had first installed the above driver files, but these are for desktop graphics cards, so the driver installation failed. But i use a Laptop.
For laptop there is a "Mobility driver version 10.12, " available
"10-12_mobility_vista_win7_64_dd_ccc.exe"
With this file, the installation worked.

Magic Bullet Looks now works wonderfully

Thank you for this great help
Déclic Vidéo FX
#Déclic Vidéo FX
Sunday, March 6, 2011 6:07 AM
GREAT ! And thanks for the feedback.

DV FX
Graham P.
#Graham P.
Saturday, March 12, 2011 3:36 PM
Success at last.For those of you who have navidia cards, with out driver issues, it can be a systems app.that is stopping it.I had to go into system configuration and turn off half and half again until I found it(Windows event log).Now whether or not it is the same app.(not sure on the proper term,my last computer class was 1972) on your machine I don't know as I am using Windows 7.I turned the bugger off and voila there was looks builder in all it's glory.That and the HFX creator are my two favorite apps..Remember you saw it here first.
Déclic Vidéo FX
#Déclic Vidéo FX
Sunday, March 13, 2011 6:18 AM
Very good information Graham, I will add it to the article.
Thanks,

DV FX
JoJoJo
#JoJoJo
Thursday, April 14, 2011 1:48 AM
Does anybody have experience with the newest ATI Catalyst Driver V11.3.
Is Magic Bulllet now working with this Driver ?
JoJoJo
#JoJoJo
Friday, April 15, 2011 1:54 AM
I have now installed the newest ATI Catalyst Driver 11.3 an my Laptop.
MB-Looks works now without Errors
Déclic Vidéo FX
#Déclic Vidéo FX
Friday, April 15, 2011 1:21 PM
Thanks for the feedback JoJoJo.
;-)

DV FX
Norman Ford
#Norman Ford
Monday, June 13, 2011 10:24 AM
What am I doing wrong? I have downloaded the latest files and run them as you say above, but my driver for my ATI HD 3650 is not updating. It still shows as 8.762.0.0 dated 08/03/2010. I have used the default ATI directories that the program gives me (C:\Program Files\ATI Technologies). Are these right or should I install in a different directory?
Déclic Vidéo FX
#Déclic Vidéo FX
Wednesday, June 15, 2011 4:00 PM
Can you try the latest driver ? Sometimes, an upgrade is not going as it should..... Unfortunately, I have no idea for such case.

DV FX
Norman Ford
#Norman Ford
Saturday, June 18, 2011 5:14 AM
Thanks for your reply. I have downloaded catalyst manager and drivers (11-5 dated 29th May 2011). No joy. I have also downloaded versions 11-6 dated 15th June 2011. With the latter, it appears that neither contains a display driver. Although one is uninstalled, there is not one in the list to install. Also, I cannot find their email address to contact them about it.
Déclic Vidéo FX
#Déclic Vidéo FX
Saturday, June 18, 2011 9:44 AM
No more idea, sorry.... Anyone else ?

DV
PLME888
#PLME888
Wednesday, January 4, 2012 3:02 PM
Hello,
I have Pinnacle Studio 15 HD Ultimate Collection with magic bullet but my magic bullet won't render the vid...
I have a Toshiba Windows 7 64 bit, 4GB RAM, 320GB, 128MB GPU family or something and it won't render it...
When i open magic bullet everything works fine but wen I want to "make" my movie... I get a black screen -_-'
Can somebody help me please?? It is annoying...
Thanks
Déclic Vidéo FX
#Déclic Vidéo FX
Thursday, January 5, 2012 3:04 AM
Hello PLME888,

Many users have reported a similar problem with TOSHIBA portable computer and 2 graphics card. Unfortunately, so far, there is no solution....
(excepted changing portable computer).

If you find a solution, please let us known, many users will probably be happy.

DV FX
Gert Oskar Reitner
#Gert Oskar Reitner
Wednesday, August 1, 2012 7:21 PM
Hi !
I do not have the required card installed and therefore I uninstalled Magic Bullet Looks . I was hoping that it would also eliminate the Card Message every time I start Studio and have no idea wheere it now comes from ?


Regards
Gert

Déclic Vidéo FX
#Déclic Vidéo FX
Thursday, August 2, 2012 11:04 AM
Did you upgrade your video card driver to the latest one ?

DV FX
Gert Oskar Reitner
#Gert Oskar Reitner
Thursday, August 2, 2012 4:30 PM
No I do not want to upgrade as I do not have the required Video Card ! I have UNINSTALLED it and cant get the message deleted ??
Regards
Gert
Déclic Vidéo FX
#Déclic Vidéo FX
Saturday, August 4, 2012 2:00 PM
Sorry, I don't understand your problem.

DV FX
Gert Oskar Reitner
#Gert Oskar Reitner
Saturday, August 4, 2012 2:50 PM
When Pinnacle Studio and Magic Bullet is installed and the proper Video Card is NOT installed a MESSAGE comes up saying that it is required ! This Error Message can be Cancelled and Pinnacle Studio resumes loading . I uninstalled Magic Bullet BUT the message still keeps coming up when loading Studio and I need to find this annoying message to get rid of it !
Déclic Vidéo FX
#Déclic Vidéo FX
Sunday, August 5, 2012 3:12 AM
Hello Gert,

I have no idea for this problem, sorry...
:-(
Uninstall and re-install ??

DV FX
 

Post Comment


WARNING: this comment section only relates to the current article. All technical and/or general questions regarding software detailled in our article *MUST* be asked through various forums; we won't even answer to comments which do not comply to this basic rule, and we might even moderate it. Thanks in advance for your comprehension.

Comments support tags : [quote]Text[/quote], [b]Text[/b], [i]Text[/i], [u]Text[/u], [url]www.sample.com[/url] or [url=www.sample.com]Link name[/url].
You can use these tags to highlight your text or insert a link in your comment.

Name or surname (required) - publicly visible on the website

Email (required)

Website

CAPTCHA image
Enter the code shown above: